主机、VPS、域名优惠信息

【WordPress】觉得WordPress 5.x版本不好用?来学学如何对WordPress版本降级!

 

WordPress从5.4升级到5.5出现了很多的变化,导致我们升级后出现了很多BUG,而且汉化一直没有跟上,再加上也没有重大的安全隐患发现,并且升级没有本质上面出现什么变化,都是官方的人在瞎折腾,不是么?

回想一下WordPress从4.9.x到5.x有啥重大的改变么?有的,那就是增加了一个傻逼编辑器-Gutenberg。这种反人类的编辑器,从5.0开始强制替换了默认的经典编辑器,并且官方一直在反对声中不断前进,不断开发…WordPress官方网站上的插件里面下载量超过500万的实际上只有8个,其中有7个都是经历了好多年积累下载才到500万的,但是唯独“Classic Editor”这个经典编辑器这个插件在最近一年内下载量猛彪…可想而已,这是一个多么傻逼的事情!

有兴趣的人可以试着把WordPress5.x降级到4.9.17或者其他版本!

插件降级,先安装一个插件:

然后我们在后台激活插件,接下来就很简单了,输入你要降级到WordPress某个具体版本的版本号,比如输入4.9.17,接下来插件会自动下载这个WordPress文件开始覆盖(说一下,如果你需要的这个版本没有中文版,你可以编辑具体下载文件的URL,选英文版就可以了,升级成功后自己把中文版的语言包上传进去就可以用了),然后下一步…

不用插件,手动降级

下载你需要的那个旧版本的WordPress文件包,解压这个旧包,然后删除旧包里面的wp-content这个文件夹(直接删除),其余的保留不变;接下来,我们通过FTP等将旧文件覆盖服务器上的比较新文件,最后访问对应的 “http(s)://domain/wp-admin/”,会看到提示你更新数据库,点击一下,就完成了降级了!

降级有风险,不管是插件还是手工处理,请先备份数据!比较保险的做法是下载一份数据在自己的电脑上localhost环境下降级,然后再恢复到自己的生产环境里面,这样相对安全不少!

WordPress所有版本查询:

 

原创文章如转载请注明:美国主机资讯站

相关文章

  • 暂无相关文章

发表评论

*

* 绝不会泄露


Design By HostChoose | Power By Hostchoose